Twenty'em 1.2.2: Actualización a Bootstrap v4.0.0-beta.2 y jQuery 3.0.0

Disponible para descargar Twenty'em 1.2.2 totalmente compatible con Bootstrap v4.0.0-beta.2 y jQuery 3.0.0

Notas Generales

Twenty'em 1.2.2 es una actualización menor que busca como objetivo fundamental estar actualizado con Bootstrap v4.0.0. Actualmente dicho framework corre su versión 4.0.0-beta.2, que a su vez usa jQuery 3.0.0, una versión superior a la que trae WordPress por defecto.

Dado el caso, nos hemos visto en la encrucijada de esperar a ver si el equipo de WordPress da el salto a jQuery 3.0.0 o hacer esta actualización. Y en efecto, aquí estamos, hemos actualizado a la versión 3.0.0 de jQuery:

// Dequeue old jQuery
wp_deregister_script('jquery');
// Enqueue jQuery 3.0.0 to support Bootstrap jQuery plugins
wp_register_script( 'jquery', t_em_get_js( 'jquery' ), array(), $t_em_theme_data['Version'], true );
wp_enqueue_script( 'jquery' );

Atención

Esto puede traer problemas de compatibilidad con algún plugin, así que recomendamos tener esto en cuenta.

Actualizaciones

  • Bootstrap v4.0.0-beta.2
  • jQuery v3.0.0

Mejoras

Agregadas nuevas funciones:

  • t_em_get_post_excerpt()
  • t_em_get_js()
  • t_em_get_css()

Eliminaciones

  • Eliminado el archivo /js/html5-shiv.js

Descargar Twenty'em 1.2.2

Puedes descargar Twenty'em v1.2.2 desde nuestro repositorio en GitHub. De igual manera recomendamos usar nuestro Child Theme.

Descargar Twenty'em v1.2.2

Compartir: Twenty'em 1.2.2: Actualización a Bootstrap v4.0.0-beta.2 y jQuery 3.0.0

No hay respuestas para: Twenty'em 1.2.2: Actualización a Bootstrap v4.0.0-beta.2 y jQuery 3.0.0

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *